学堂 学堂 学堂公众号手机端

hdu2680 Choose the best route (dijkstra)

lewis 1年前 (2024-04-15) 阅读数 11 #技术


Choose the best route




Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)


Total Submission(s): 11571Accepted Submission(s): 3762




Problem Description


One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.




Input


There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.




Output


The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.




Sample Input


5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1




Sample Output


1 -1




Author


dandelion




Source


​​2009浙江大学计算机研考复试(机试部分)——全真模拟​​




Recommend


lcy|We have carefully selected several similar problems for you: ​​1142​​​ ​​​2923​​​ ​​​1690​​​ ​​​1596​​​ ​​​2722​​



解析:逆向建图,单向边。

代码:


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn=1e3;
int edge[maxn+5][maxn+5];
int n,s,f[maxn+5];
bool used[maxn+5];

void dijkstra()
{
memset(f,10,sizeof(f)),f[s]=0;
memset(used,0,sizeof(used));

int i,j,k;
for(i=1;i<n;i++)
{
for(k=0,j=1;j<=n;j++)
if(!used[j] && f[j]<f[k])k=j;
used[k]=1;
for(j=1;j<=n;j++)
f[j]=min(f[j],f[k]+edge[k][j]);
}
}

int main()
{
//freopen("1.in","r",stdin);

int m,i,j,k;
while(scanf("%d%d%d",&n,&m,&s)==3)
{
memset(edge,10,sizeof(edge));
while(m--)
{
scanf("%d%d%d",&i,&j,&k);
edge[j][i]=min(edge[j][i],k);
}
dijkstra();
for(j=f[0],scanf("%d",&k);k;k--)
scanf("%d",&i),j=min(j,f[i]);
printf("%d\n",(j==f[0])?-1:j);
}
return 0;
}



版权声明

本文仅代表作者观点,不代表博信信息网立场。

热门